import Foundation
let pattern = #"(\d) +(?=%)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test 12 %
test 1.2 %
test 1,2 % 2.5 %
% test 1,2 % 2.5 % something
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)