use strict;
my $str = '{http://www.w3.org/2003/05/soap-envelope}Sender||BEA-382505 : OSB Validate action failed validation||<soap12-env:Detail xmlns:soap12-env="http://www.w3.org/2003/05/soap-envelope"><fault><errorCode xmlns:soap12-env="http://www.w3.org/2003/05/soap-envelope">BEA-382505</errorCode><reason>OSB Validate action failed validation</reason><details><ValidationFailureDetail><message>string value \'ROM\' is not a valid enumeration value for CountryAlpha3CodeSimpleType in namespace http://release.niem.gov/niem/codes/nga_genc/3.0/</message><xmlLocation><LocationCountryGENCCode>ROM</LocationCountryGENCCode></xmlLocation></ValidationFailureDetail></details><location><node>PipelinePairNode5</node><pipeline>PipelinePairNode5_request</pipeline><stage>ValidateMessage</stage><path>request-pipeline</path></location></fault></soap12-env:Detail>';
my $regex = qr/<\w[^>]*>(?=<)|(?<=>)<\/\w[^>]*>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}