import Foundation
let pattern = #"<\w[^>]*>(?=<)|(?<=>)<\/\w[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{http://www.w3.org/2003/05/soap-envelope}Sender||BEA-382505 : OSB Validate action failed validation||<soap12-env:Detail xmlns:soap12-env="http://www.w3.org/2003/05/soap-envelope"><fault><errorCode xmlns:soap12-env="http://www.w3.org/2003/05/soap-envelope">BEA-382505</errorCode><reason>OSB Validate action failed validation</reason><details><ValidationFailureDetail><message>string value 'ROM' is not a valid enumeration value for CountryAlpha3CodeSimpleType in namespace http://release.niem.gov/niem/codes/nga_genc/3.0/</message><xmlLocation><LocationCountryGENCCode>ROM</LocationCountryGENCCode></xmlLocation></ValidationFailureDetail></details><location><node>PipelinePairNode5</node><pipeline>PipelinePairNode5_request</pipeline><stage>ValidateMessage</stage><path>request-pipeline</path></location></fault></soap12-env:Detail>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)