import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "redb?\\.(?:(?<dpi>dpi)|(?<port>port)|fb_width|fb_height)=\"\\K\\w+";
final String string = "bst.instance.red.port=\"5555\"\n"
+ "bst.instance.red.dpi=\"240\"\n"
+ "bst.instance.red.fb_height=\"900\"\n"
+ "bst.instance.red.fb_width=\"1600\"\n"
+ "bst.instance.red.first_boot=\"0\"\n"
+ "bst.instance.redb.port=\"2000\"\n"
+ "bst.instance.redb.dpi=\"120\"\n"
+ "bst.instance.redb.fb_height=\"300\"\n"
+ "bst.instance.redb.fb_width=\"800\"\n"
+ "bst.instance.redb.first_boot=\"0\"\n"
+ "bst.instance.redc.port=\"2000\"\n"
+ "bst.instance.redc.dpi=\"120\"\n"
+ "bst.instance.redc.fb_height=\"300\"\n"
+ "bst.instance.redc.fb_width=\"800\"\n"
+ "bst.instance.redc.first_boot=\"0\"";
final String subst = "${dpi:+YYY:}${port:+WWW:}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}