# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"redb?\.(?:(?<dpi>dpi)|(?<port>port)|fb_width|fb_height)=\"\K\w+"
test_str = ("bst.instance.red.port=\"5555\"\n"
"bst.instance.red.dpi=\"240\"\n"
"bst.instance.red.fb_height=\"900\"\n"
"bst.instance.red.fb_width=\"1600\"\n"
"bst.instance.red.first_boot=\"0\"\n"
"bst.instance.redb.port=\"2000\"\n"
"bst.instance.redb.dpi=\"120\"\n"
"bst.instance.redb.fb_height=\"300\"\n"
"bst.instance.redb.fb_width=\"800\"\n"
"bst.instance.redb.first_boot=\"0\"\n"
"bst.instance.redc.port=\"2000\"\n"
"bst.instance.redc.dpi=\"120\"\n"
"bst.instance.redc.fb_height=\"300\"\n"
"bst.instance.redc.fb_width=\"800\"\n"
"bst.instance.redc.first_boot=\"0\"")
subst = "${dpi:+YYY:}${port:+WWW:}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.