package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/\?)|(?:artist=([^&]*))|(?:title=([^&]*))|(?:album=([^&]*))|(?:year=([^&]*))|(?:type=([^&]*))`)
var str = `/?artist=MyArtist&title=MyTitle&album=TheBestOf&year=2019&type=Music
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}