#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=.{1,64}@)(?:("[^"\\]*(?:\\.[^"\\]*)*"@)|((?:[0-9a-z](?:\.(?!\.)|[-!#\$%&'\*\+\/=\?\^`\{\}\|~\w])*)?[0-9a-z]@))(?=.{1,255}$)(?:(\[(?:\d{1,3}\.){3}\d{1,3}\])|((?:(?=.{1,63}\.)[0-9a-z][-\w]*[0-9a-z]*\.)+[a-z0-9][\-a-z0-9]{0,22}[a-z0-9])|((?=.{1,63}$)[0-9a-z][-\w]*))$"
Local $sString = "// Mix valid/invalid" & @CRLF & _
"" & @CRLF & _
"david.jones@proseware.com" & @CRLF & _
"d.j@server1.proseware.com" & @CRLF & _
"jones@ms1.proseware.com" & @CRLF & _
"j.@server1.proseware.com" & @CRLF & _
"j@proseware.com9" & @CRLF & _
"js#internal@proseware.com" & @CRLF & _
"j_9@[129.126.118.1]" & @CRLF & _
"j..s@proseware.com" & @CRLF & _
"js*@proseware.com" & @CRLF & _
"js@proseware..com" & @CRLF & _
"js@proseware.com9" & @CRLF & _
"j.s@server1.proseware.com" & @CRLF & _
""j\"s\""@proseware.com" & @CRLF & _
"js@contoso.中国.com" & @CRLF & _
"" & @CRLF & _
"=========================================" & @CRLF & _
"" & @CRLF & _
"// Valid" & @CRLF & _
"" & @CRLF & _
"simple@example.com" & @CRLF & _
"very.common@example.com" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"other.email-with-hyphen@example.com" & @CRLF & _
"fully-qualified-domain@example.com" & @CRLF & _
"user.name+tag+sorting@example.com" & @CRLF & _
"fully-qualified-domain@example.com" & @CRLF & _
"x@example.com" & @CRLF & _
"carlosd'intino@arnet.com.ar" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"admin@mailserver1" & @CRLF & _
"example@s.example" & @CRLF & _
"" "@example.org" & @CRLF & _
""john..doe"@example.org" & @CRLF & _
"" & @CRLF & _
"// Invalid" & @CRLF & _
"" & @CRLF & _
"Abc.example.com" & @CRLF & _
"A@b@c@example.com" & @CRLF & _
"a\"b(c)d,e:f;g<h>i[j\\k]l@example.com" & @CRLF & _
"just\"not\"right@example.com" & @CRLF & _
"this is\"not\\allowed@example.com" & @CRLF & _
"this\\ still\"not\\allowed@example.com" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com" & @CRLF & _
"john..doe@example.com" & @CRLF & _
"john.doe@example..com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")