import re
regex = re.compile(r"(?im)^(?=.{1,64}@)(?:(\"[^\"\\]*(?:\\.[^\"\\]*)*\"@)|((?:[0-9a-z](?:\.(?!\.)|[-!#\$%&'\*\+\/=\?\^`\{\}\|~\w])*)?[0-9a-z]@))(?=.{1,255}$)(?:(\[(?:\d{1,3}\.){3}\d{1,3}\])|((?:(?=.{1,63}\.)[0-9a-z][-\w]*[0-9a-z]*\.)+[a-z0-9][\-a-z0-9]{0,22}[a-z0-9])|((?=.{1,63}$)[0-9a-z][-\w]*))$")
test_str = ("// Mix valid/invalid\n\n"
"david.jones@proseware.com\n"
"d.j@server1.proseware.com\n"
"jones@ms1.proseware.com\n"
"j.@server1.proseware.com\n"
"j@proseware.com9\n"
"js#internal@proseware.com\n"
"j_9@[129.126.118.1]\n"
"j..s@proseware.com\n"
"js*@proseware.com\n"
"js@proseware..com\n"
"js@proseware.com9\n"
"j.s@server1.proseware.com\n"
"\"j\\\"s\\\"\"@proseware.com\n"
"js@contoso.中国.com\n\n"
"=========================================\n\n"
"// Valid\n\n"
"simple@example.com\n"
"very.common@example.com\n"
"disposable.style.email.with+symbol@example.com\n"
"other.email-with-hyphen@example.com\n"
"fully-qualified-domain@example.com\n"
"user.name+tag+sorting@example.com\n"
"fully-qualified-domain@example.com\n"
"x@example.com\n"
"carlosd'intino@arnet.com.ar\n"
"example-indeed@strange-example.com\n"
"admin@mailserver1\n"
"example@s.example\n"
"\" \"@example.org\n"
"\"john..doe\"@example.org\n\n"
"// Invalid\n\n"
"Abc.example.com\n"
"A@b@c@example.com\n"
"a\\\"b(c)d,e:f;g<h>i[j\\\\k]l@example.com\n"
"just\\\"not\\\"right@example.com\n"
"this is\\\"not\\\\allowed@example.com\n"
"this\\\\ still\\\"not\\\\allowed@example.com\n"
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com\n"
"john..doe@example.com\n"
"john.doe@example..com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")