import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?im)^(?=.{1,64}@)(?:(\"[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"@)|([0-9a-z](?:\\.(?!\\.)|[-!#\\$%&'\\*\\+\\/=\\?\\^`\\{\\}\\|~\\w])*@))(?=.{1,255}$)(?:(\\[(?:\\d{1,3}\\.){3}\\d{1,3}\\])|((?:(?=.{1,63}\\.)[0-9a-z][-\\w]*[0-9a-z]*\\.)+[a-z0-9][\\-a-z0-9]{0,22}[a-z0-9])|((?=.{1,63}$)[0-9a-z][-\\w]*))$";
final String string = "// Mix valid/invalid\n\n"
+ "david.jones@proseware.com\n"
+ "d.j@server1.proseware.com\n"
+ "jones@ms1.proseware.com\n"
+ "j.@server1.proseware.com\n"
+ "j@proseware.com9\n"
+ "js#internal@proseware.com\n"
+ "j_9@[129.126.118.1]\n"
+ "j..s@proseware.com\n"
+ "js*@proseware.com\n"
+ "js@proseware..com\n"
+ "js@proseware.com9\n"
+ "j.s@server1.proseware.com\n"
+ "\"j\\\"s\\\"\"@proseware.com\n"
+ "js@contoso.中国.com\n\n"
+ "=========================================\n\n"
+ "// Valid\n\n"
+ "sudhansu_@gmail.com\n"
+ "simp_le@example.com\n"
+ "very.common@example.com\n"
+ "disposable.style.email.with+symbol@example.com\n"
+ "other.email-with-hyphen@example.com\n"
+ "fully-qualified-domain@example.com\n"
+ "user.name+tag+sorting@example.com\n"
+ "fully-qualified-domain@example.com\n"
+ "x@example.com\n"
+ "carlosd'intino@arnet.com.ar\n"
+ "example-indeed@strange-example.com\n"
+ "admin@mailserver1\n"
+ "example@s.example\n"
+ "\" \"@example.org\n"
+ "\"john..doe\"@example.org\n\n"
+ "// Invalid\n\n"
+ "Abc.example.com\n"
+ "A@b@c@example.com\n"
+ "a\\\"b(c)d,e:f;g<h>i[j\\\\k]l@example.com\n"
+ "just\\\"not\\\"right@example.com\n"
+ "this is\\\"not\\\\allowed@example.com\n"
+ "this\\\\ still\\\"not\\\\allowed@example.com\n"
+ "1234567890123456789012345678901234567890123456789012345678901234+x@example.com\n"
+ "john..doe@example.com\n"
+ "john.doe@example..com\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}