# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?im)^(?=.{1,64}@)(?:(\"[^\"\\]*(?:\\.[^\"\\]*)*\"@)|([0-9a-z](?:\.(?!\.)|[-!#\$%&'\*\+\/=\?\^`\{\}\|~\w])*@))(?=.{1,255}$)(?:(\[(?:\d{1,3}\.){3}\d{1,3}\])|((?:(?=.{1,63}\.)[0-9a-z][-\w]*[0-9a-z]*\.)+[a-z0-9][\-a-z0-9]{0,22}[a-z0-9])|((?=.{1,63}$)[0-9a-z][-\w]*))$"
test_str = ("// Mix valid/invalid\n\n"
"david.jones@proseware.com\n"
"d.j@server1.proseware.com\n"
"jones@ms1.proseware.com\n"
"j.@server1.proseware.com\n"
"j@proseware.com9\n"
"js#internal@proseware.com\n"
"j_9@[129.126.118.1]\n"
"j..s@proseware.com\n"
"js*@proseware.com\n"
"js@proseware..com\n"
"js@proseware.com9\n"
"j.s@server1.proseware.com\n"
"\"j\\\"s\\\"\"@proseware.com\n"
"js@contoso.中国.com\n\n"
"=========================================\n\n"
"// Valid\n\n"
"sudhansu_@gmail.com\n"
"simp_le@example.com\n"
"very.common@example.com\n"
"disposable.style.email.with+symbol@example.com\n"
"other.email-with-hyphen@example.com\n"
"fully-qualified-domain@example.com\n"
"user.name+tag+sorting@example.com\n"
"fully-qualified-domain@example.com\n"
"x@example.com\n"
"carlosd'intino@arnet.com.ar\n"
"example-indeed@strange-example.com\n"
"admin@mailserver1\n"
"example@s.example\n"
"\" \"@example.org\n"
"\"john..doe\"@example.org\n\n"
"// Invalid\n\n"
"Abc.example.com\n"
"A@b@c@example.com\n"
"a\\\"b(c)d,e:f;g<h>i[j\\\\k]l@example.com\n"
"just\\\"not\\\"right@example.com\n"
"this is\\\"not\\\\allowed@example.com\n"
"this\\\\ still\\\"not\\\\allowed@example.com\n"
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com\n"
"john..doe@example.com\n"
"john.doe@example..com\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.