$re = '/"[^"]*"|\S+|\s+/';
$str = '[4,4] "This is fun"
2 2 +
#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);