package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)(?:\.\((\d{4}\-\d{2}\-\d{2}\s)?([^\)]*)\))?(?:\.(.+))?$`)
var str = `O.(2008-08-27).Animation
Avatar 2 - la voie de l'eau.(2022-12-14)
Prey.(2022-08-05 Disney+)
Star Wars- The Clone Wars.(2008-08-27).Animation
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}