// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+?)(?:\.\((\d{4}\-\d{2}\-\d{2}\s)?([^\)]*)\))?(?:\.(.+))?$").unwrap();
let string = "O.(2008-08-27).Animation
Avatar 2 - la voie de l'eau.(2022-12-14)
Prey.(2022-08-05 Disney+)
Star Wars- The Clone Wars.(2008-08-27).Animation
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}