$re = '/(.{5,}?)\1+$/m';
$str = 'hahahahahahaha
spam spam spam spam spam spam
looooooooooool
aaaaaaaaaaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);