re = /(.{5,}?)\1+$/m
str = 'hahahahahahaha
spam spam spam spam spam spam
looooooooooool
aaaaaaaaaaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end