$re = '/(?<!@)@/m';
$str = 'hello @jon i am @@here or @@@there and want some@thing in \'@here"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);