re = /(?<!@)@/m
str = 'hello @jon i am @@here or @@@there and want some@thing in \'@here"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end