#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?:\'\,\[\]\)\d{0,10}\ then\ begin\s?)^(.*?)\bend;"
Local $sString = "e R$ '+FormatFloat('#,##0.00', valorPercentual )" & @CRLF & _
" else" & @CRLF & _
" FieldByName('InstrucoesMultaVencimento').Value := '';" & @CRLF & _
" end;" & @CRLF & _
"" & @CRLF & _
" if oCDS_CONVENIOBANCARIOCOBREBEMPROP.Locate('CBC_NOMEPROPRIEDADE','InstrucoesDiasProtesto',[]) then begin" & @CRLF & _
" AlteraDescricaoInstrucao := oCDS_CONVENIOBANCARIOCOBREBEMPROP.FieldByName('CBC_VALORPROPRIEDADE').AsString;" & @CRLF & _
" AlteraDescricaoInstrucao := StringReplace( AlteraDescricaoInstrucao,'#DIA#', FloatToStr(oCds_ConvenioBanco.FieldByName('CBP_PROTESTODIAS').AsFloat),[rfReplaceAll, rfIgnoreCase]);" & @CRLF & _
" FieldByName('InstrucoesDiasProtesto').Value := AlteraDescricaoInstrucao;" & @CRLF & _
" end else begin" & @CRLF & _
" if ( oCds_ConvenioBanco.FieldByName('CBP_PROTESTODIAS').AsFloat > 0 ) then" & @CRLF & _
" FieldByName('InstrucoesDiasProtesto').Value := 'Após '+IntToStr(oCds_ConvenioBanco.FieldByName('CBP_PROTESTODIAS').AsInteger)+' dias do vencimento protestar'" & @CRLF & _
" else" & @CRLF & _
" FieldByName('InstrucoesDiasProtesto').Value := ''; end;" & @CRLF & _
"" & @CRLF & _
" if ( oCds_ConvenioBanco.FieldByName('CBP_CALCULAVALORJURO').AsString = 'P' ) then" & @CRLF & _
" valorJuroDiario := ( ( BoletoBancario.ConvenioBancario.ValorDocumento * oCds_ConvenioBanco.FieldByName('CBP_PERCENTUALJUROSDIARIO').AsFloat) / 100)" & @CRLF & _
" else" & @CRLF & _
" valorJuroDiario := oCds_ConvenioBanco.FieldByName('CBP_PERCENTUALJUROSDIARIO').AsFloat;" & @CRLF & _
"" & @CRLF & _
" if oCDS_CONVENIOBANCARIOCOBREBEMPROP.Locate('CBC_NOMEPROPRIEDADE','InstrucoesJurosDiario',[]) then" & @CRLF & _
" FieldByName('InstrucoesJurosDiario').Value := oCDS_CONVENIOBANCARIOCOBREBEMPROP.FieldByName('CBC_VALORPROPRIEDADE').AsString" & @CRLF & _
" else begin" & @CRLF & _
" if ( oCds_ConvenioBanco.FieldByName('CBP_PERCENTUALJUROSDIARIO').AsFloat > 0 ) then" & @CRLF & _
" FieldByName('InstrucoesJurosDiario').Value := 'Após vencimento cobrar juros de R$ '+FormatFloat('#,##0.00', valorJuroDiario)+' por dia de atraso.'" & @CRLF & _
" else" & @CRLF & _
" FieldByName('InstrucoesJurosDiario').Value := ''" & @CRLF & _
" end;" & @CRLF & _
"" & @CRLF & _
" if ( BoletoBancario.ConvenioBancario.OutrasInstrucoes <> '' ) then" & @CRLF & _
" OutrasIntrucoes := oCds_ConvenioBanco.FieldByName('CBB_OUTRASINSTRUCOES').AsString" & @CRLF & _
" else" & @CRLF & _
" OutrasIntrucoes := '';" & @CRLF & _
"" & @CRLF & _
" if ( NumeroNFSe <> 'SemNumero' ) then{#T31720}" & @CRLF & _
" OutrasIntrucoes := OutrasIntrucoes + 'Boleto ref. a Notas: ' + NumeroNFSe; // NumeroNF; {#T31549}" & @CRLF & _
"" & @CRLF & _
" if ( NumeroNF <> 'SemNumero' ) then begin{#T31720}" & @CRLF & _
" if ( OutrasIntrucoes <> '') then begin" & @CRLF & _
" OutrasIntrucoes := OutrasIntrucoes+#13#10+ 'RPS: ' + NumeroNF; // NumeroNFSe; {#T31549}" & @CRLF & _
" end else" & @CRLF & _
" OutrasIntrucoes := 'Boleto ref. a RPS: ' + NumeroNF; // NumeroNFSe; {#T31549}" & @CRLF & _
" end;varToStr( copy( BoletoBancario.ConvenioBancario.NumeroContaCorrente, Length(BoletoBancario.ConvenioBancario.NumeroContaCorrente), 1));" & @CRLF & _
"" & @CRLF & _
" FieldByName('NomeSacado').Value := IntToStr(BoletoBancario.CodigoCliente)+' - '+BoletoBancario.NomeCliente;" & @CRLF & _
" FieldByName('RuaSacado').Value := oCds_TitulosSelecionados.FieldByName('CLN_ENDERECO').AsString+', Nº '+" & @CRLF & _
" oCds_TitulosSelecionados.FieldByName('CLN_NUMERO').AsString;" & @CRLF & _
"" & @CRLF & _
" cepCliente := FormatMaskText('99999-999;0;', oCds_TitulosSelecionados.FieldByName('CEP_CEP').AsString);" & @CRLF & _
" FieldByName('CidadeEstadoCep').Value := cepCliente+' '+" & @CRLF & _
" BoletoBancario.CidadeCliente+'-'+" & @CRLF & _
" BoletoBancario.EstadoCliente;" & @CRLF & _
"" & @CRLF & _
" Carteira := Codig"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")