import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\'\\,\\[\\]\\)\\d{0,10}\\ then\\ begin\\s?)^(.*?)\\bend;";
final String string = "e R$ '+FormatFloat('#,##0.00', valorPercentual )\n"
+ " else\n"
+ " FieldByName('InstrucoesMultaVencimento').Value := '';\n"
+ " end;\n\n"
+ " if oCDS_CONVENIOBANCARIOCOBREBEMPROP.Locate('CBC_NOMEPROPRIEDADE','InstrucoesDiasProtesto',[]) then begin\n"
+ " AlteraDescricaoInstrucao := oCDS_CONVENIOBANCARIOCOBREBEMPROP.FieldByName('CBC_VALORPROPRIEDADE').AsString;\n"
+ " AlteraDescricaoInstrucao := StringReplace( AlteraDescricaoInstrucao,'#DIA#', FloatToStr(oCds_ConvenioBanco.FieldByName('CBP_PROTESTODIAS').AsFloat),[rfReplaceAll, rfIgnoreCase]);\n"
+ " FieldByName('InstrucoesDiasProtesto').Value := AlteraDescricaoInstrucao;\n"
+ " end else begin\n"
+ " if ( oCds_ConvenioBanco.FieldByName('CBP_PROTESTODIAS').AsFloat > 0 ) then\n"
+ " FieldByName('InstrucoesDiasProtesto').Value := 'Após '+IntToStr(oCds_ConvenioBanco.FieldByName('CBP_PROTESTODIAS').AsInteger)+' dias do vencimento protestar'\n"
+ " else\n"
+ " FieldByName('InstrucoesDiasProtesto').Value := ''; end;\n\n"
+ " if ( oCds_ConvenioBanco.FieldByName('CBP_CALCULAVALORJURO').AsString = 'P' ) then\n"
+ " valorJuroDiario := ( ( BoletoBancario.ConvenioBancario.ValorDocumento * oCds_ConvenioBanco.FieldByName('CBP_PERCENTUALJUROSDIARIO').AsFloat) / 100)\n"
+ " else\n"
+ " valorJuroDiario := oCds_ConvenioBanco.FieldByName('CBP_PERCENTUALJUROSDIARIO').AsFloat;\n\n"
+ " if oCDS_CONVENIOBANCARIOCOBREBEMPROP.Locate('CBC_NOMEPROPRIEDADE','InstrucoesJurosDiario',[]) then\n"
+ " FieldByName('InstrucoesJurosDiario').Value := oCDS_CONVENIOBANCARIOCOBREBEMPROP.FieldByName('CBC_VALORPROPRIEDADE').AsString\n"
+ " else begin\n"
+ " if ( oCds_ConvenioBanco.FieldByName('CBP_PERCENTUALJUROSDIARIO').AsFloat > 0 ) then\n"
+ " FieldByName('InstrucoesJurosDiario').Value := 'Após vencimento cobrar juros de R$ '+FormatFloat('#,##0.00', valorJuroDiario)+' por dia de atraso.'\n"
+ " else\n"
+ " FieldByName('InstrucoesJurosDiario').Value := ''\n"
+ " end;\n\n"
+ " if ( BoletoBancario.ConvenioBancario.OutrasInstrucoes <> '' ) then\n"
+ " OutrasIntrucoes := oCds_ConvenioBanco.FieldByName('CBB_OUTRASINSTRUCOES').AsString\n"
+ " else\n"
+ " OutrasIntrucoes := '';\n\n"
+ " if ( NumeroNFSe <> 'SemNumero' ) then{#T31720}\n"
+ " OutrasIntrucoes := OutrasIntrucoes + 'Boleto ref. a Notas: ' + NumeroNFSe; // NumeroNF; {#T31549}\n\n"
+ " if ( NumeroNF <> 'SemNumero' ) then begin{#T31720}\n"
+ " if ( OutrasIntrucoes <> '') then begin\n"
+ " OutrasIntrucoes := OutrasIntrucoes+#13#10+ 'RPS: ' + NumeroNF; // NumeroNFSe; {#T31549}\n"
+ " end else\n"
+ " OutrasIntrucoes := 'Boleto ref. a RPS: ' + NumeroNF; // NumeroNFSe; {#T31549}\n"
+ " end;varToStr( copy( BoletoBancario.ConvenioBancario.NumeroContaCorrente, Length(BoletoBancario.ConvenioBancario.NumeroContaCorrente), 1));\n\n"
+ " FieldByName('NomeSacado').Value := IntToStr(BoletoBancario.CodigoCliente)+' - '+BoletoBancario.NomeCliente;\n"
+ " FieldByName('RuaSacado').Value := oCds_TitulosSelecionados.FieldByName('CLN_ENDERECO').AsString+', Nº '+\n"
+ " oCds_TitulosSelecionados.FieldByName('CLN_NUMERO').AsString;\n\n"
+ " cepCliente := FormatMaskText('99999-999;0;', oCds_TitulosSelecionados.FieldByName('CEP_CEP').AsString);\n"
+ " FieldByName('CidadeEstadoCep').Value := cepCliente+' '+\n"
+ " BoletoBancario.CidadeCliente+'-'+\n"
+ " BoletoBancario.EstadoCliente;\n\n"
+ " Carteira := Codig";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}