import re
regex = re.compile(r"(?<![a-zA-Z])[0-9][\.0-9]*(?![a-zA-Z])")
test_str = ("Theses are some of the fail cases that I am looking to \n"
"avoid variable123 or variable_123name or _123_,\n"
"where some of the acceptable cases are |123| or +123+ $123 123% #124523 ext... 11 2123 123% 0.12 1.1.3.4.4 12 1 23452 23423| ext...[")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")