$re = '/(.*(?!CP)) ((?=CP|UP).*) ((?=CP|UP).*)/m';
$str = 'Kanwil Palembang Area Jambi CP Bengkulu CP Bengkulu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);