re = /(.*(?!CP)) ((?=CP|UP).*) ((?=CP|UP).*)/m
str = 'Kanwil Palembang Area Jambi CP Bengkulu CP Bengkulu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end