$re = '/^\d{1,9}$|^[1-3]d{9}$|^4[1-1]d{8}$|^42[1-8]d{7}$|^429[1-3]d{6}$|^4294[1-8]d{5}$|^42949[1-5]d{4}$|^429496[1-6]d{3}$|^4294967[1-1]d{2}$|^42949672[1-8]d{1}$|^429496729[1-4]d{0}$|^4294967295$/';
$str = '4294967295';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);