// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\d{1,9}$|^[1-3]d{9}$|^4[1-1]d{8}$|^42[1-8]d{7}$|^429[1-3]d{6}$|^4294[1-8]d{5}$|^42949[1-5]d{4}$|^429496[1-6]d{3}$|^4294967[1-1]d{2}$|^42949672[1-8]d{1}$|^429496729[1-4]d{0}$|^4294967295$").unwrap();
let string = "4294967295";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}