package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0{2,}$`)
var str = `000
9
0
2234
34
00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}