$re = '/^0{2,}$/m';
$str = '000
9
0
2234
34
00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);