#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Item([1-9]|[1-4][0-9]|50)$"
Local $sString = "Winst" & @CRLF & _
"Item1" & @CRLF & _
"Item2" & @CRLF & _
"Item3" & @CRLF & _
"Item4" & @CRLF & _
"Item5" & @CRLF & _
"Item6" & @CRLF & _
"Item7" & @CRLF & _
"Item8" & @CRLF & _
"Item9" & @CRLF & _
"Item10" & @CRLF & _
"Item11" & @CRLF & _
"Item12" & @CRLF & _
"Item13" & @CRLF & _
"Item14" & @CRLF & _
"Item15" & @CRLF & _
"Item16" & @CRLF & _
"Item17" & @CRLF & _
"Item18" & @CRLF & _
"Item19" & @CRLF & _
"Item20" & @CRLF & _
"Item21" & @CRLF & _
"Item22" & @CRLF & _
"Item23" & @CRLF & _
"Item24" & @CRLF & _
"Item25" & @CRLF & _
"Item26" & @CRLF & _
"Item27" & @CRLF & _
"Item28" & @CRLF & _
"Item29" & @CRLF & _
"Item30" & @CRLF & _
"Item31" & @CRLF & _
"Item32" & @CRLF & _
"Item33" & @CRLF & _
"Item34" & @CRLF & _
"Item35" & @CRLF & _
"Item36" & @CRLF & _
"Item37" & @CRLF & _
"Item38" & @CRLF & _
"Item39" & @CRLF & _
"Item40" & @CRLF & _
"Item41" & @CRLF & _
"Item42" & @CRLF & _
"Item43" & @CRLF & _
"Item44" & @CRLF & _
"Item45" & @CRLF & _
"Item46" & @CRLF & _
"Item47" & @CRLF & _
"Item48" & @CRLF & _
"Item49" & @CRLF & _
"Item50" & @CRLF & _
"Item51" & @CRLF & _
"Item52" & @CRLF & _
"Item53" & @CRLF & _
"Item54" & @CRLF & _
"Item55" & @CRLF & _
"Item56" & @CRLF & _
"Item57" & @CRLF & _
"Item58" & @CRLF & _
"Item59" & @CRLF & _
"Item60" & @CRLF & _
"Item61" & @CRLF & _
"Item62" & @CRLF & _
"Item63" & @CRLF & _
"Item64" & @CRLF & _
"Item65" & @CRLF & _
"Item66" & @CRLF & _
"Item67" & @CRLF & _
"Item68" & @CRLF & _
"Item69" & @CRLF & _
"Item70" & @CRLF & _
"Item71" & @CRLF & _
"Item72" & @CRLF & _
"Item73" & @CRLF & _
"Item74" & @CRLF & _
"Item75" & @CRLF & _
"Item76" & @CRLF & _
"Item77" & @CRLF & _
"Item78" & @CRLF & _
"Item79" & @CRLF & _
"Item80" & @CRLF & _
"Item81" & @CRLF & _
"Item82" & @CRLF & _
"Item83" & @CRLF & _
"Item84" & @CRLF & _
"Item85" & @CRLF & _
"Item86" & @CRLF & _
"Item87" & @CRLF & _
"Item88" & @CRLF & _
"Item89" & @CRLF & _
"Item90" & @CRLF & _
"Item91" & @CRLF & _
"Item92" & @CRLF & _
"Item93" & @CRLF & _
"Item94" & @CRLF & _
"Item95" & @CRLF & _
"Item96" & @CRLF & _
"Item97" & @CRLF & _
"Item98" & @CRLF & _
"Item99" & @CRLF & _
"Item100 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")