import Foundation
let pattern = #"^Item([1-9]|[1-4][0-9]|50)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Winst
Item1
Item2
Item3
Item4
Item5
Item6
Item7
Item8
Item9
Item10
Item11
Item12
Item13
Item14
Item15
Item16
Item17
Item18
Item19
Item20
Item21
Item22
Item23
Item24
Item25
Item26
Item27
Item28
Item29
Item30
Item31
Item32
Item33
Item34
Item35
Item36
Item37
Item38
Item39
Item40
Item41
Item42
Item43
Item44
Item45
Item46
Item47
Item48
Item49
Item50
Item51
Item52
Item53
Item54
Item55
Item56
Item57
Item58
Item59
Item60
Item61
Item62
Item63
Item64
Item65
Item66
Item67
Item68
Item69
Item70
Item71
Item72
Item73
Item74
Item75
Item76
Item77
Item78
Item79
Item80
Item81
Item82
Item83
Item84
Item85
Item86
Item87
Item88
Item89
Item90
Item91
Item92
Item93
Item94
Item95
Item96
Item97
Item98
Item99
Item100
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)