package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^.*a(?s:.*?)blu.*`)
var str = `1538 a
123
skua456
789
5
g
15563 blu55g
b
456
16453 a
789
5
16524 blu
g
55
1734 a
987
987
55
aasf
552
18278 blu
ttry`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}