import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^.*a(?s:.*?)blu.*";
final String string = "1538 a\n"
+ "123\n"
+ "skua456\n"
+ "789\n"
+ "5\n"
+ "g\n"
+ "15563 blu55g\n"
+ "b\n"
+ "456\n"
+ "16453 a\n"
+ "789\n"
+ "5\n"
+ "16524 blu\n"
+ "g\n"
+ "55\n"
+ "1734 a\n"
+ "987\n"
+ "987\n"
+ "55\n"
+ "aasf\n"
+ "552\n"
+ "18278 blu\n"
+ "ttry";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}