#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^.*a(?:\n.*)*?\n.*blu.*"
Local $sString = "1538 a" & @CRLF & _
"123" & @CRLF & _
"skua456" & @CRLF & _
"789" & @CRLF & _
"5" & @CRLF & _
"g" & @CRLF & _
"15563 blu55g" & @CRLF & _
"b" & @CRLF & _
"456" & @CRLF & _
"16453 a" & @CRLF & _
"789" & @CRLF & _
"5" & @CRLF & _
"16524 blu" & @CRLF & _
"g" & @CRLF & _
"55" & @CRLF & _
"1734 a" & @CRLF & _
"987" & @CRLF & _
"987" & @CRLF & _
"55" & @CRLF & _
"aasf" & @CRLF & _
"552" & @CRLF & _
"18278 blu" & @CRLF & _
"ttry"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")