# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^.*a(?:\n.*)*?\n.*blu.*"
test_str = ("1538 a\n"
"123\n"
"skua456\n"
"789\n"
"5\n"
"g\n"
"15563 blu55g\n"
"b\n"
"456\n"
"16453 a\n"
"789\n"
"5\n"
"16524 blu\n"
"g\n"
"55\n"
"1734 a\n"
"987\n"
"987\n"
"55\n"
"aasf\n"
"552\n"
"18278 blu\n"
"ttry")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.