using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^( *urls *= *\[)((""(?!tac-temp10)([a-zA-Z0-9_-]*)"",? *)*)(\] #tac)$";
string input = @"[[inputs.ping]]
urls = [""tac-temp1"",""tac-temp2"",""tac-temp3"",""tac-temp4""] #tac
count = 30
timeout = 15.0
[inputs.ping.tags]
name = ""tac""
[[inputs.ping]]
urls = [""prod-temp1"",""prod-temp2"", ""prod-temp3"",""prod-temp4""] #prod
count = 30
timeout = 15.0
[inputs.ping.tags]
name = ""prod""
[[inputs.ping]]
urls = [""test-temp1"",""test-temp2"", ""test-temp3"",""test-temp4""] #test
count = 30
timeout = 15.0
[inputs.ping.tags]
name = ""test""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}