import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^( *urls *= *\\[)((\"(?!tac-temp10)([a-zA-Z0-9_-]*)\",? *)*)(\\] #tac)$";
final String string = "[[inputs.ping]]\n"
+ " urls = [\"tac-temp1\",\"tac-temp2\",\"tac-temp3\",\"tac-temp4\"] #tac\n"
+ " count = 30\n"
+ " timeout = 15.0\n"
+ " [inputs.ping.tags]\n"
+ " name = \"tac\"\n\n"
+ "[[inputs.ping]]\n"
+ " urls = [\"prod-temp1\",\"prod-temp2\", \"prod-temp3\",\"prod-temp4\"] #prod\n"
+ " count = 30\n"
+ " timeout = 15.0\n"
+ " [inputs.ping.tags]\n"
+ " name = \"prod\"\n\n"
+ "[[inputs.ping]]\n"
+ " urls = [\"test-temp1\",\"test-temp2\", \"test-temp3\",\"test-temp4\"] #test\n"
+ " count = 30\n"
+ " timeout = 15.0\n"
+ " [inputs.ping.tags]\n"
+ " name = \"test\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}