package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#([^.]*)`)
var str = `anything#aaabbbccc.dddeee.fff
anything#aaabbbccc.dddeee
anything#aaabbbccc.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}