re = /#([^.]*)/m
str = 'anything#aaabbbccc.dddeee.fff
anything#aaabbbccc.dddeee
anything#aaabbbccc.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end