re = /(.*?[0-9][0-9]\/[0-9][0-9]\/[0-9][0-9]){2,}/
str = 'SMART PRODUCTS 0.50 0.76 0.79 05/09/16 1000 1.02 1.02 27/06/16 17/06/11 27/06/16 0
SMART PRODUCTS 0.50 0.76 0.79 17/06/11 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end