package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(?:km|rua)+\s*\D+?"`)
var str = `rua 5", "rua x, casa y", "km 18", "km x"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}