use strict;
my $str = '// VALID
example.near
example.testnet
sub.xtrtarstsrt3322.testnet
1sub.sub.near
12.near
aa.testnet
1a.a3a.near
deltron-me.testnet
deltron_yes.near
// INVALID because of the capital letter but we can lowercase it on db
Fmish.testnet
// INVALID
aa.setetstestnet
_sentaent.testnet
-howabout.this.near
space should fail.testnet
space should fail.near
!testnet.testnet
2a!.near
n.testnet
shouldnotendwithperiod.testnet.
aa.t.testnet
1a..near
touchingDotsShouldfail..testnet
.aa.testnet';
my $regex = qr/^(([A-Za-z\d]+[\-_])*[A-Za-z\d]{2,}\.)*(?:testnet|near)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}