$re = '/^(([A-Za-z\d]+[\-_])*[A-Za-z\d]{2,}\.)*(?:testnet|near)$/m';
$str = '// VALID
example.near
example.testnet
sub.xtrtarstsrt3322.testnet
1sub.sub.near
12.near
aa.testnet
1a.a3a.near
deltron-me.testnet
deltron_yes.near
// INVALID because of the capital letter but we can lowercase it on db
Fmish.testnet
// INVALID
aa.setetstestnet
_sentaent.testnet
-howabout.this.near
space should fail.testnet
space should fail.near
!testnet.testnet
2a!.near
n.testnet
shouldnotendwithperiod.testnet.
aa.t.testnet
1a..near
touchingDotsShouldfail..testnet
.aa.testnet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);