import re
regex = re.compile(r"^-?(?=\d{1,15}(?:[.,]0+)?0*$|(?:(?=.{1,16}0*$)(?:\d+[.,]\d+))).+$", flags=re.MULTILINE)
test_str = ("// PASS\n"
"0\n"
"0.00\n"
"1\n"
"-1\n"
"1.23456789012345\n"
"10.2345678901234\n"
"12.3456789012345\n"
"-123.4\n"
"-12.34\n"
"-1,33\n"
"-1.33\n"
"-123456789012345\n"
"-1234567890123450\n"
"-12345678901234.50\n"
"12345678901234.50\n"
"123456789012345.00\n\n"
"// FAIL\n"
"-1234567890123456\n"
"-12345678901234.56\n"
"12345678901234.56\n"
"123456789012345.60\n"
"1.234567890123456\n"
"12.34567890123456\n"
"123456789012340.6\n"
"123456789012300.67\n"
"123456789012300000000000.67\n"
"10000000000010000000001000010000000001.22")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")