# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(-?(?=\d{1,15}(?:[.,]0+)?0*$|(?:(?=[,.\d]{1,16}0*$)(?:\d+[.,]\d{1,2}$))).{1,16}).*$"
test_str = ("// PASS\n"
"0\n"
"0.12\n"
"1\n"
"-1\n"
"1.23456789012345\n"
"10.2345678901234\n"
"12.3456789012345\n"
"-123.4\n"
"-12.34\n"
"-1,33\n"
"-1.33\n"
"-1.333\n"
"-1234567.12\n"
"-1234567890123450\n"
"-12345678901234.50\n"
"12345678901234.50\n"
"123456789012345.00\n\n"
"// FAIL\n"
"-1234567890123456\n"
"-12345678901234.56\n"
"12345678901234.56\n"
"123456789012345.60\n"
"1.234567890123456\n"
"12.34567890123456\n"
"123456789012340.6\n"
"123456789012300.67\n"
"123456789012300000000000.67\n"
"10000000000010000000001000010000000001.22")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.