re = /^(-?(?=\d{1,15}(?:[.,]0+)?0*$|(?:(?=[,.\d]{1,16}0*$)(?:\d+[.,]\d{1,2}$))).{1,16}).*$/m
str = '// PASS
0
0.12
1
-1
1.23456789012345
10.2345678901234
12.3456789012345
-123.4
-12.34
-1,33
-1.33
-1.333
-1234567.12
-1234567890123450
-12345678901234.50
12345678901234.50
123456789012345.00
// FAIL
-1234567890123456
-12345678901234.56
12345678901234.56
123456789012345.60
1.234567890123456
12.34567890123456
123456789012340.6
123456789012300.67
123456789012300000000000.67
10000000000010000000001000010000000001.22'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result