$re = '/(?<=% )\b\d+(?:,\d+)\b|\b\d+(?:,\d+)?(?= %)/m';
$str = 'Käuferprovision: 3 % zzgl. gesetzl. MwSt.
Käuferprovision: Die Courtage i.H.v. % 3,57 inkl. MwSt. ist';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);