re = /(?<=% )\b\d+(?:,\d+)\b|\b\d+(?:,\d+)?(?= %)/m
str = 'Käuferprovision: 3 % zzgl. gesetzl. MwSt.
Käuferprovision: Die Courtage i.H.v. % 3,57 inkl. MwSt. ist'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end