#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\w[-.\w]+\.(com|org|net)\b"
Local $sString = "Test strings" & @CRLF & _
"hello.com hello1.com 1hello.com hello-1.com hello-hi1.com 1hello-hi.com h3ll0.com" & @CRLF & _
"" & @CRLF & _
"also matches" & @CRLF & _
"hello_1.com" & @CRLF & _
"---.com" & @CRLF & _
"1234.org" & @CRLF & _
"-.net" & @CRLF & _
"a.net" & @CRLF & _
"abc.comical" & @CRLF & _
"www.company.com" & @CRLF & _
"this is a sentance about net-working.networking is bla bla bla" & @CRLF & _
"" & @CRLF & _
"will not match other domains" & @CRLF & _
"hello.co.uk" & @CRLF & _
"hello.co" & @CRLF & _
"subdomain.hello.com" & @CRLF & _
"" & @CRLF & _
"correctly grabs the domain for" & @CRLF & _
"abc.com&foobar" & @CRLF & _
"abc.com/foobar" & @CRLF & _
"abc.com?foobar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")