# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b\w[-.\w]+\.(com|org|net)\b"
test_str = ("Test strings\n"
"hello.com hello1.com 1hello.com hello-1.com hello-hi1.com 1hello-hi.com h3ll0.com\n\n"
"also matches\n"
"hello_1.com\n"
"---.com\n"
"1234.org\n"
"-.net\n"
"a.net\n"
"abc.comical\n"
"www.company.com\n"
"this is a sentance about net-working.networking is bla bla bla\n\n"
"will not match other domains\n"
"hello.co.uk\n"
"hello.co\n"
"subdomain.hello.com\n\n"
"correctly grabs the domain for\n"
"abc.com&foobar\n"
"abc.com/foobar\n"
"abc.com?foobar")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.