#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w-\.+]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([\w-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$"
Local $sString = "Invalid:" & @CRLF & _
"mkyong" & @CRLF & _
"mkyong123@.com" & @CRLF & _
"mkyong()*@gmail.com" & @CRLF & _
"mkyong@%*.com" & @CRLF & _
"mkyong..2002@gmail.com" & @CRLF & _
"mkyong.@gmail.com" & @CRLF & _
"mkyong@mkyong@gmail.com" & @CRLF & _
"mkyong@gmail.com.1a" & @CRLF & _
"" & @CRLF & _
"Valid:" & @CRLF & _
"mkyong@yahoo.com" & @CRLF & _
"mkyong-100@yahoo.com" & @CRLF & _
"mkyong.100@yahoo.com" & @CRLF & _
"mkyong111@mkyong.com" & @CRLF & _
"mkyong-100@mkyong.net" & @CRLF & _
"mkyong.100@mkyong.com.au" & @CRLF & _
"mkyong@1.com" & @CRLF & _
"mkyong@gmail.com.com" & @CRLF & _
"mkyong-100@yahoo-test.com" & @CRLF & _
"a.a@ac.cc.cc" & @CRLF & _
"mkyong@fdg" & @CRLF & _
".dgfsdfg@dgf.dfg" & @CRLF & _
"mkyong+123@df.com" & @CRLF & _
"firstname+lastname@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")