package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\\[0-7]{1,3})`)
var str = `\041
5
\235
048
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}