$re = '/(\\\\[0-7]{1,3})/m';
$str = '\\041
5
\\235
048
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);